Köra schemalagda aktiviteter i bakgrunden

Köra schemalagda aktiviteter regelbundet

Schemaläggaren är ett verktyg som du kan använda för att schemalägga program (t ex Diskdefragmenteraren) så att de regelbundet körs när det passar dig. Schemaläggaren startar varje gång du startar Windows och körs sedan i bakgrunden.

Du kan starta Schemaläggaren genom att klicka på Start, peka på Program, Tillbehör, Systemverktyg och sedan klicka på Schemalagda aktiviteter.

Om du öppnar Schemaläggaren kan du:

  • Schemalägga en aktivitet så att den körs varje dag, vecka eller månad eller vid särskilda tillfällen, till exempel när datorn startas eller inte är upptagen med annat.
  • Ändra schemat eller inaktivera det för en befintlig aktivitet.
  • Ange hur en schemalagd aktivitet ska köras.


Så här schemalägger du en ny aktivitet

  1. Klicka på Start, peka på Program, Tillbehör, Systemverktyg och klicka sedan på Schemalagda aktiviteter.
  2. Dubbelklicka på Lägg till schemalagd aktivitet.
  3. Följ anvisningarna i guiden Schemalagda aktiviteter.

    4. Om du vill ange avancerade inställningar för aktiviteten (t ex att den ska upprepas varje gång den körs) måste du markera kryssrutan Öppna avancerade egenskaper för aktiviteten när du klickar på Slutför på den sista skärmbilden i guiden.

Obs!

  • Om aktivitetsprogrammet kräver parametrar markerar du kryssrutan Öppna avancerade egenskaper för aktiviteten när du klickar på Slutför på den sista skärmbilden i guide och klickar sedan på fliken Aktivitet och skriver in parametrarna i rutan Kör efter aktivitetssökvägen.
  • Så länge datorn är påslagen körs en schemalagd aktivitet oberoende av om någon är inloggad eller inte. Om du inte vill att aktiviteter ska köras när ingen är inloggad öppnar du mappen Schemalagda aktiviteter innan du loggar ut och klickar på Inaktivera Schemaläggaren på Avancerat-menyn. Om du vill använda Schemaläggaren igen öppnar du mappen Schemalagda aktiviteter och klickar på Aktivera Schemaläggaren på Avancerat-menyn.
  • Kontrollera att systemdatum och systemtid för datorn är korrekt inställda. Schemaläggaren använder informationen när den kör schemalagda aktiviteter. Om du vill ändra datum och tid dubbelklickar du på tiden på Aktivitetsfältet.

Närliggande information


Så här ändrar du en schemalagd aktivitet

  1. Klicka på Start, peka på Program, Tillbehör, Systemverktyg och klicka sedan på Schemalagda aktiviteter.
  2. Högerklicka på den aktivitet du vill ändra och klicka sedan på Egenskaper.
  3. Välj ett av följande alternativ:
    • Om du vill köra ett annat program skriver du in sökvägen för aktiviteten i rutan Kör eller också klickar du på Bläddra.
    • Om du vill ändra schemat för en aktivitet klickar du på fliken Schema.
    • Om du vill anpassa inställningarna för en aktivitet klickar du på fliken Inställningar.

Obs!

  • Om aktivitetsprogrammet kräver parametrar skriver du dem i rutan Kör efter sökvägen för aktiviteten.
  • Om sökvägen till aktivitetsprogrammet innehåller blanksteg, skriver du citattecken (“) före och efter hela sökvägen.


Så här tar du bort en schemalagd aktivitet

  1. Klicka på Start, peka på Program, Tillbehör, Systemverktyg och klicka sedan på Schemalagda aktiviteter.
  2. Högerklicka på den aktivitet som du vill ta bort och klicka på Ta bort.

Obs!

  • Borttagning av en schemalagd aktivitet tar bara bort aktiviteten från schemat. Programmet som är kopplat till aktiviteten tas inte bort från datorn.


Så här avbryter du en schemalagd aktivitet som körs

  1. Klicka på Start, peka på Program, Tillbehör, Systemverktyg och klicka sedan på Schemalagda aktiviteter.
  2. Högerklicka på den aktivitet som du vill stoppa och klicka sedan på Avsluta aktivitet.

Obs!

  • Om en schemalagd aktivitet startar ett annat program avbryter det här kommandot endast den första schemalagda aktiviteten och inte den andra.
  • Om du vill starta om aktiviteten högerklickar du på aktiviteten och klickar på Kör.
  • Så länge datorn är påslagen körs en schemalagd aktivitet oberoende av om någon är inloggad eller inte. Om du inte vill att aktiviteter ska köras när ingen är inloggad öppnar du mappen Schemalagda aktiviteter innan du loggar ut och klickar på Inaktivera Schemaläggaren på Avancerat-menyn. Om du vill använda Schemaläggaren igen öppnar du mappen Schemalagda aktiviteter och klickar på Aktivera Schemaläggaren på Avancerat-menyn.


Så här kör du en aktivitet omedelbart

  1. Klicka på Start, peka på Program, Tillbehör, Systemverktyg och klicka sedan på Schemalagda aktiviteter.
  2. Högerklicka på den aktivitet som du vill starta och klicka sedan på Kör.

Obs!

  • Du kan avsluta aktiviteten genom att klicka på Avsluta Schemalagd aktivitet på Arkiv-menyn.
  • Om en aktivitet inte går att köra kontrollerar du vad det beror på i loggfilen. Klicka på Visa logg på Avancerat-menyn.


Så här visar du en logg med tidigare schemalagda aktiviteter

  1. Klicka på Start, peka på Program, Tillbehör, Systemverktyg och klicka sedan på Schemalagda aktiviteter.
  2. Klicka på Visa logg på Avancerat-menyn.


Så här visar du schemalagda aktiviteter på en fjärransluten dator

  1. Dubbelklicka på Mina nätverksplatser på skrivbordet.
  2. Dubbelklicka på den dator som du vill visa schemalagda aktiviteter på.
  3. Dubbelklicka på mappen Schemalagda aktiviteter.

Obs!

  • Du kan endast redigera aktiviteter på en fjärransluten dator som har installerat programvara för fjärregister och delar x$-resursen, där x är den hårddisk som innehåller mappen Schemalagda aktiviteter. Du måste även ange att ditt användarkonto har tillgång till fjärregister. Du kan ange vilka användare som ska ha tillgång till fjärregister på en dator genom att dubbelklicka på ikonen Lösenord i Kontrollpanelen.


Så här stänger du tillfälligt av alla schemalagda aktiviteter

  1. Klicka på Start, peka på Program, Tillbehör, Systemverktyg och klicka sedan på Schemalagda aktiviteter.
  2. Klicka på Pausa Schemaläggaren på Avancerat-menyn.

    Det här är användbart när du kör ett annat program (t ex ett spel) eller installerar program och inte vill köra schemalagda aktiviteter samtidigt.

Obs!

  • Aktiviteter som skulle ha körts under tiden som Schemaläggaren är pausad körs vid nästa schemalagda tillfälle.
  • Om du vill återuppta de schemalagda aktiviteterna klickar du på Fortsätt med Schemaläggaren på Avancerat-menyn.


Så här inaktiverar du Schemaläggaren

  1. Klicka på Start, peka på Program, Tillbehör, Systemverktyg och klicka sedan på Schemalagda aktiviteter.
  2. Klicka på Inaktivera Schemaläggaren på Avancerat-menyn.

Obs!

  • När du inaktiverar Schemaläggaren kommer inga schemalagda aktiviteter att köras och Schemaläggaren kommer inte att startas automatiskt nästa gång du startar Windows.


Felsökning: Schemaläggaren

Om den schemalagda aktiviteten inte körs när du förväntar dig att den ska köras högerklickar du på aktiviteten i aktivitetslistan och klickar på Egenskaper. Kontrollera att kryssrutan Aktiverad är markerad på fliken Aktivitet. Kontrollera att schemat är korrekt inställt på fliken Schema.

Om ett aktivitetsprogram inte körs korrekt kan det hända att du måste ange kommandoargument för programmet. Om du vill ha mer information om ett program och dess argument gör du så här:

  • Om programmet innehåller en direkthjälp kan du titta i den.
  • Ange följande i en kommandoprompt. Ange programmets namn där det står program:
    program /?


Dubbelklicka på mappen Schemalagda aktiviteter.

  • Klicka på Start, peka på Program, Tillbehör, Systemverktyg och klicka sedan på Schemalagda aktiviteter.